Новые коммутаторы агрегации SNR-S2995G и SNR-S3850G

Новые коммутаторы построены на пакетных процессорах одного из лидеров отрасли – компании Marvell. В серии SNR-S2995G используются чипсеты семейства AlleyCat3, а в SNR-S3850G – более продвинутые в плане маршрутизации, PonCat3.

Сравнительные характеристики чипсетов приведены в таблице:

ASIC AlleyCat3 (SNR-S2995G) PonCat3 (SNR-S3850G)
Интерфейсы 24xGE; 4x10GE 24xGE; 4x10GE
CPU Single-Core ARM Dual-Core ARM
Таблица MAC 16К 16К
Таблица ARP
IPv4 LPM 13К
На текущий момент серия SNR-S2995G представлена двумя моделями. Первая, это стандартный коммутатор агрегации SNR-S2995G-24FX с 24 портами SFP (8 из которых комбо) + 4 аплинка 1/10GE SFP+. Вторая модель – SNR-S2995G-12FX –  является уникальным коммутатором на 12 SFP-портов (4 комбо) и 4 порта 1/10GE SFP+.В первом квартале 2019 г. планируется расширение серии моделями:
  • SNR-S2995G-24TX – 24×10/100/1000BaseT и 4×1/10GE SFP+
  • SNR-S2995G-48TX – 48×10/100/1000BaseT и 4×1/10GE SFP+

и долгожданным коммутатором агрегации на 48 SFP портов:

  • SNR-S2995G-48FX – 48×100/1000BaseX и 4×1/10GE SFP+.

Серия SNR-S3850G представлена одной моделью – это L3-коммутатор агрегации SNR-S3850G-24FX, оснащенный 24 портами SFP (8 из которых комбо) и 4 аплинками 1/10GE.Так как новые коммутаторы проектировались в первую очередь для операторов связи, они оснащены RPS-портом 12В с мониторингом AC-питания, который позволяет с небольшими затратами зарезервировать электропитание узла связи и обеспечить большое время автономной работы.

На данный момент уже доступны модифицированные модели SNR-S2995G-24FX-UPS и SNR-S3850G-24FX-UPS с возможностью прямого подключения 12В АКБ. Коммутатор автоматически контролирует процесс заряда и разряда АКБ, а также оповещает о переходе с основного питания на АКБ и обратно.
Данные коммутаторы поддерживают функцию “холодный старт” – при замене разряженной АКБ на новую, коммутатор автоматически запустится, если напряжение на новой АКБ будет не менее 12,5 В.
Динамическая зарядка с током до 3 А позволяет в сжатые сроки зарядить АКБ высокой емкости после длительного отсутствия электроэнергии. Тесты показали 12 часов непрерывной работы коммутаторов с полной нагрузкой и подключенным АКБ 40Ач, при этом полный заряд АКБ занимал до 14 часов.

Модель SNR-S2995G-12FX-UPS ожидается в конце 4 квартала 2018 г.

Так как архитектурно чипсеты AlleyCat3 и PonCat3 очень близки, коммутаторы SNR-S2995G и SNR-S3850G работают с одной прошивкой, а внешний вид моделей отличается только названием модели на передней панели.

С точки зрения функционала, коммутаторы SNR-S2995G и SNR-S3850G одинаковы, различия только в CPU и размере таблиц маршрутизации. Основные характеристики приведены в таблице:

L2 4K VLAN, LACP 802.3ad, STP/RSTP/MSTP, ERPS G.8032, Vlan-translation, QinQ/Selective QinQ
L3 OSPF, BGP, PIM, MSDP
L2 Multicast IGMP Snooping, MLD Snooping, MVR
Security L2-L4 port/vlan-based ACL, User-defined ACL, Port-security, IP-MAC-Port-Binding, Broadcast/Multicast/Unicast storm control
QoS 8 очередей на порт, SP/WDRR/SP+WDRR, маркировка/перемаркировка 802.1p,DSCP

Как видно из таблицы, функционал коммутаторов стандартный для оборудования такого класса.

Обе модели могут работать на полной скорости портов без переподписки:

Модель Коммутационная матрица Скорость пересылки пакетов
SNR-S2995G-12FX 104 Gbps 83 Mpps
SNR-S2995G-24FX 128 Gbps 95 Mpps
SNR-S3850G-24FX 128 Gbps 95 Mpps

В коммутаторах используется стандартный для всех коммутаторов SNR Cisco-like CLI и MIB, то есть интеграция в сеть не составит проблем. Для примера настроим на коммутаторах простую схему с PIM и OSPF:

 Настройка OSPF и PIM на SNR-S2995G:Для подключения консольным кабелем необходимо использовать скорость 115200 бод.

Для удобства настроим loopback-интерфейс:

config terminal
interface loopback 1
ip address 10.10.10.2 255.255.255.255

Включаем PIM-маршрутизацию и настраиваем RP:

ip pim multicast-routing
ip pim rp-address 10.10.10.2

Далее настроим интерфейс в сторону источника Multicast-трафика:

vlan 777
interface vlan 777
ip address 10.100.100.1 255.255.255.0
ip pim sparse-mode passive
interface ethernet 1/0/27
switchport mode trunk
switchport trunk allowed vlan 777

А также OSPF:

vlan 3300
interface vlan 3300
ip address 172.16.1.2 255.255.255.252
ip pim sparse-mode
interface ethernet 1/0/28
switchport mode trunk
switchport trunk allowed vlan 3300
router ospf 1
ospf router-id 10.10.10.2
network 10.10.10.2 0.0.0.0 area 0
network 172.16.1.0 0.0.0.3 area 0
network 10.100.100.0 0.0.0.255 area 0
passive-interface Loopback1
passive-interface vlan 77

SNR-S3850G настраивается аналогично:

config terminal
interface loopback 1
ip address 10.10.10.1 255.255.255.255

ip pim multicast-routing
ip pim rp-address 10.10.10.2

vlan 200
interface vlan 200
ip address 192.168.200.1 255.255.255.0
vlan 100
interface vlan 100
ip address 192.168.100.1 255.255.255.0
ip pim sparse-mode passive
interface ethernet 1/0/27
switchport mode trunk
switchport trunk allowed vlan 100
ip igmp snooping
ip igmp snooping vlan 100

vlan 3300
interface vlan 3300
ip address 172.16.1.1 255.255.255.252
ip pim sparse-mode
interface ethernet 1/0/28
switchport mode trunk
switchport trunk allowed vlan 3300
router ospf 1
ospf router-id 10.10.10.1
network 10.10.10.1 0.0.0.0 area 0
network 172.16.1.0 0.0.0.3 area 0
network 192.168.200.0 0.0.0.255 area 0
passive-interface vlan 200
passive-interface Loopback1

Убедимся в установлении соседства OSPF и получаемых маршрутах:

SNR-S2995G-24FX#show ip ospf neighbor
OSPF process 1:
Neighbor ID     Pri State      Dead Time Address      Interface
10.10.10.1        1 Full/Backup  00:00:38 172.16.1.1      Vlan3300

SNR-S3850G-24FX#show ip ospf neighbor
OSPF process 1:
Neighbor ID     Pri State      Dead Time Address      Interface
10.10.10.2        1 Full/DR  00:00:33 172.16.1.2      Vlan3300

SNR-S2995G-24FX#show ip route ospf
O       10.10.10.1/32 [110/2] via 172.16.1.1, Vlan3300, 00:52:44  tag:0
O       192.168.200.0/24 [110/2] via 172.16.1.1, Vlan3300, 00:52:44  tag:0

SNR-S3850G-24FX#show ip route ospf
O       10.10.10.2/32 [110/2] via 172.16.1.2, Vlan3300, 00:52:56  tag:0
O       10.100.100.0/24 [110/2] via 172.16.1.2, Vlan3300, 00:03:01  tag:0

Также проверим PIM-соседство:

SNR-S2995G-24FX#show ip pim neighbor
Neighbor          Interface          Uptime/Expires    Ver   DR
Address                                                      Priority/Mode
172.16.1.1        Vlan3300           00:54:43/00:01:34 v2    1 /

SNR-S3850G-24FX#show ip pim neighbor
Neighbor          Interface          Uptime/Expires    Ver   DR
Address                                                      Priority/Mode
172.16.1.2        Vlan3300           01:15:49/00:01:29 v2    1 / DR

После включения в сеть источника Multicast-трафика убедимся в получении маршрута Multicast-трафика:

SNR-S2995G-24FX#show ip pim mroute sparse-mode
(10.100.100.2, 239.255.1.1)
RPF nbr: 0.0.0.0
RPF idx: None
SPT bit: 1
Upstream State: NOT JOINED
Local     ……………………………………………………….
Joined    ……………………………………………………….
Asserted  ……………………………………………………….
Boundary  ……………………………………………………….
Outgoing  ……………………………………………………….
(10.100.100.2, 239.255.1.1, rpt)
RP: 0.0.0.0
RPF nbr: 0.0.0.0
RPF idx: None
Upstream State: RPT NOT JOINED
Pruned    ……………………………………………………….
Outgoing  ……………………………………………………….

Настройка MVR на SNR-S2985G:

config terminal
vlan 100
multicast-vlan
vlan 200
ip igmp snooping
ip igmp snooping vlan 100
ip igmp snooping vlan 100 mrouter-port interface Ethernet1/0/28
interface ethernet 1/0/28
switchport trunk allowed vlan add 100,200
interface ethernet 1/0/24
switchport access vlan 200
switchport association multicast-vlan 100

Проверим состояние PIM и IGMP:

SNR-S2995G-24FX#show ip pim mroute sparse-mode
(*, 239.255.1.1)
RP: 10.10.10.2
RPF nbr: 0.0.0.0
RPF idx: None
Upstream State: JOINED
Local     ……………………………………………………….
Joined    j………………………………………………………
Asserted  ……………………………………………………….
FCR:
(10.100.100.2, 239.255.1.1)
RPF nbr: 0.0.0.0
RPF idx: None
SPT bit: 1
Upstream State: JOINED
Local     ……………………………………………………….
Joined    j………………………………………………………
Asserted  ……………………………………………………….
Boundary  ……………………………………………………….
Outgoing  o………………………………………………………
(10.100.100.2, 239.255.1.1, rpt)
RP: 10.10.10.2
RPF nbr: 0.0.0.0
RPF idx: None
Upstream State: NOT PRUNED
Pruned    ……………………………………………………….
Outgoing  o………………………………………………………

SNR-S3850G-24FX#show ip pim mroute sparse-mode
IP Multicast Routing Table
(*,*,RP) Entries: 0
(*,G) Entries: 1
(S,G) Entries: 1
(S,G,rpt) Entries: 1
FCR Entries: 0
(*, 239.255.1.1)
RP: 10.10.10.2
RPF nbr: 172.16.1.2
RPF idx: Vlan3300
Upstream State: JOINED
Local     .l……………………………………………………..
Joined    ……………………………………………………….
Asserted  ……………………………………………………….
FCR:
(10.100.100.2, 239.255.1.1)
RPF nbr: 172.16.1.2
RPF idx: Vlan3300
SPT bit: 1
Upstream State: JOINED
Local     ……………………………………………………….
Joined    ……………………………………………………….
Asserted  ……………………………………………………….
Boundary  ……………………………………………………….
Outgoing  .o……………………………………………………..
(10.100.100.2, 239.255.1.1, rpt)
RP: 10.10.10.2
RPF nbr: 172.16.1.2
RPF idx: Vlan3300
Upstream State: NOT PRUNED
Pruned    ……………………………………………………….
Outgoing  .o……………………………………………………..

SNR-2985G-24TC#show ip igmp snooping vlan 100 groups
IGMP Snooping Connect Group Membership
Note:*-All Source, (S)- Include Source, [S]-Exclude Source
Groups          Sources             Ports               Exptime  SrcMac           System Level
239.255.1.1     *                   Ethernet1/0/10      00:02:45 D4:85:64:ED:02:E0   V3   

Как видим, коммутаторы настраиваются так же просто, как и другие модели SNR. А при относительно небольшой цене они обладают высокой производительностью и широким функционалом для использования в качестве коммутаторов доступа и L2/L3-агрегации.